sbg  

Pro-Line
Results 1 to 4 of 4

Thread: Shock issues help needed

  1. #1

    Default Shock issues help needed

    Hi all,

    I have an scx10ii and bought a set of proline pro-spec scaler shocks. I fill them with oil just bellow internal threads pump the shocks about 10 times let them sit and do another 10 or until there is no air bubbles. Cannot for the life of me get the full compression out of the shocks. They bottom about 5 mm from full compression.

    If I remove oil to the point where I get full compression I can hear it sucking air and when I open them the oil is full of air bubbles.

    Anyone know what I'm doing wrong here any help or tips would be greatly appreciated.

    -TIA!!


    Sent from my CLT-L04 using Tapatalk

  2. #2
    Join Date
    Jun 2011
    Location
    Duff Gardens
    Posts
    6,563

    Default

    First part sounds like over-filled but...is the end of the shock with the piston hitting the cap preventing full compression?
    SBG Junior Vice President in Charge of Jerps

  3. #3
    Join Date
    Jul 2010
    Location
    It no longer exists.
    Posts
    11,622

    Default

    Sounds overfilled. Some shocks need some air, otherwise, it's a hydrolock and fluid won't move.
    SBG OWNER YOUTUBE AXIAL AMBASSADOR GCM TEAM DRIVER VANQUISH KNIGHT CUSTOMS TEAM

  4. #4
    Join Date
    Nov 2017
    Location
    Nova Scotia
    Posts
    115

    Default

    I had the same this with a friends and we did same as imthatguy is telling you and that helped but my friend felt that they moved to slowly so then we put some thiner oil and then it was fixed for him. I liked them moving slowly, looked more real. Hope that you get them working just the way you like it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •