sbg  

AE Element 2
Results 1 to 7 of 7

Thread: Overheating Tekin Fx-R with Tekin 55T HD on TF2...

  1. #1
    Join Date
    May 2017
    Posts
    54

    Question Overheating Tekin Fx-R with Tekin 55T HD on TF2...

    Running a Tekin Fx-R with Tekin 55T HD on a 2S Lipo. Not an uncommon setup, pavement pounding showed no issues during the typical first setup tests. Took it to the park today and it was great for about a half hour, running through grass, beach sand etc, went back on the hard pack trail and then the big slowdown and shutoff. No splishy-splashy promo shots, just normal off-roading. The ESC reads hot, but ye ol' finger test read less then warm, with cool motor and battery.

    Radio/receiver is a Spektrum DX4C w/ SRS4210 (AVS-off) and running SAVOX 0231MG waterproof servos dialed in for throw.

    Only thing I can think of is that the servo's are pulling all some amps, but with 2S setup a BEC is not necessarily required.

    The S.

  2. #2
    Join Date
    Jul 2010
    Location
    It no longer exists.
    Posts
    11,272

    Default

    You sure it wasn't just a dead battery?

    Nothing sounds out of the ordinary. But I love troubleshooting.
    SBG OWNER YOUTUBE AXIAL AMBASSADOR GCM TEAM DRIVER VANQUISH KNIGHT CUSTOMS TEAM

  3. #3
    Join Date
    May 2017
    Posts
    54

    Default

    Same here, I figured the setup was sound.

    I went out with a full charge (8.4v). I did some tests once I got home, and without a doubt its the servos that are pulling a lot of juice through the ESC's BEC. In testing at home I was able to tell the ESC was considerably warm (not necessarily hot). I cross posted on RCC and another guy stated that SAVOX servos are powerhungry.

    I picked up a Castle Creations BEC 2.0 with two servo bypass cable, that should straighten it out. I will probably replace the ESC in the upcoming weeks, in testing at home it reached the heat protection thresh-hold really quick compared to the initial shake down run at the park. Instead of turning the truck off I kept driving thinking "Oh that kink will work itself out" which turned into "F-U...WTF...why is this thing stopping" and kept clubbing the poor ESC like a baby seal, probably cutting the ESC's lifespan by 3/4.

    I'll update the post once I get everything delivered/installed/tested.

    The S.

  4. #4
    Join Date
    Jul 2010
    Location
    It no longer exists.
    Posts
    11,272

    Default

    Poor ESC. Odd that the servo's are pulling so much juice that it's messing with the ESC. Did you program your BEC for the proper volts?
    SBG OWNER YOUTUBE AXIAL AMBASSADOR GCM TEAM DRIVER VANQUISH KNIGHT CUSTOMS TEAM

  5. #5
    Join Date
    May 2017
    Posts
    54

    Default

    Yup, when ordering the CC-BEC you can specify what voltage you want it programmed, so for this servo setup I ordered it for 6v. That keeps me at the 208oz torque spec, and within the voltage parameters of the RX. Using the ol' Googler I found a lot of posts about guys running higher voltages on the BEC and the servos committing hari-kari, so 6v it is...playing it safe than sorry Charlie.

    With my luck they didn't program it and I'll have to throw more bones down for a programmer Thursday night. If you do order it don't do it from a phone, the mobile site doesn't give you the option to specify voltage programming.

    The S.

  6. #6
    Join Date
    Jul 2010
    Location
    It no longer exists.
    Posts
    11,272

    Default

    Weird, didn't know that was an option. The last one I got was set to a paltry 4v. I might have an extra programming setup - if you want it, pay for postage.

    Send me a PM.
    SBG OWNER YOUTUBE AXIAL AMBASSADOR GCM TEAM DRIVER VANQUISH KNIGHT CUSTOMS TEAM

  7. #7
    Join Date
    May 2017
    Posts
    54

    Default

    CC BEC 2.0 (waterproof) with HH Dual Servo Bypass Cable installed. All I have to say is "Dude, it's freakin' awesome". Servo performance is improved bigly. It definitely came programmed out of the box too so big plus on the customer support. I'll post up a picture of the setup, need to finish sexying up the wiring.

    This weekend I'll head back to the park for another shakedown run so I'll be able to check the performance on the Lipo. Running a 2S 5000mah, so I should get a nice long run in.

    The S.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •